Home > Creative Sound > Creative Sound Blaster X-fi Elite Pro Drivers

Creative Sound Blaster X-fi Elite Pro Drivers

Support for such products is limited to online materials, such as Knowledgebase Solutions, drivers, application updates and product documentations available on the Creative Customer Support website.Customers are also welcome to participate but until I'm sure that Creative has it's issues sorted, I'll stick with my onboard sound. I abandoned Creative back with the Audigy 2... Creative X-FI Elite Pro and Guitar Creative X-Fi Platinum vs. http://pspfull.com/creative-sound/creative-sound-blaster-x-fi-elite-drivers.html

That might also help. I was able to see it once but it was detected as a [usb type connection] with an error/code 10. when i have allowed the auto update i'll either lose the card or at minimum the use of the creative utilities. PoikaOct 5, 2009, 7:59 AM I placed it back in the original PCI slot (without the graphics card in) and still no crackling whatsoever. http://support.creative.com/Products/ProductDetails.aspx?catID=1&CatName=sound+blaster&subCatID=208&subCatName=X-Fi&prodID=14064&prodName=X-Fi+Elite+Pro

Sound & Audio X-Fi Elite Pro remote not workingHi guys, I'm on windows 7 64 bit. It is highly recommended to always use the most recent driver version available. Find More Posts by CrazeeAFGuy Page 1 of 3 1 23 > Creative SB X-FI Elite Pro Not working « Previous Thread | Next Thread » Similar help and support threads I've tried tried the modded drivers by Daniel_K, and still couldn't shake it.This problem is mostly noticeable whilst listening to music and browsing the web at the same time.

Since I was having the freezing issue, I had done another clean install, deleting all of the drivers and software that was on the computer while it had XP Pro SP3. Remember to check with our website as often as possible to stay “updated one minute ago.”

Creative Sound Blaster X-Fi Elite Pro Driver Sound Blaster X-Fi Elite Pro Audio Driver Creative Has anyone heard anything like this? Remember to check with our website as often as possible to stay “updated one minute ago.”

Creative Sound Blaster X-Fi Elite Pro Audio Driver Creative Sound Blaster X-Fi Elite Pro Card

As the same drivers versions worked together in XP. When I select a Playback Device I don't get sound if I choose Creative SB X-fi. thanks. Therefore, if you wish to install this audio version, click the download button and apply the package.

Privacy Policy feedback Articles & News Forum Graphics & Displays CPU Components Motherboards Games Storage Overclocking Tutorials All categories Chart For IT Pros Get IT Center Brands Start Menu 88. When I have the Creative SB X-fi selected as a... As it says in the original post :P frozenleadOct 5, 2009, 4:14 AM Try switching the PCI slot it's in.

I've had these Fatal1ty Creative Headphones for a year now, and I haven't had any problems in the past. http://drivers.softpedia.com/get/SOUND-CARD/CREATIVE/Creative-Sound-Blaster-X-Fi-Elite-Pro-Audio-Driver-2300007-for-Windows-10.shtml annnd there's no crackling in the other PCI slot. All rights reserved Site Map | Privacy Policy | Terms of Use | Copyright & Trademarks SOFTPEDIA Windows Drivers Games Mac Android Linux Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build.

PoikaOct 5, 2009, 10:26 AM When I placed it back in the original slot, I didn't put the video card in. http://pspfull.com/creative-sound/creative-sound-blaster-5-1-drivers-for-ubuntu.html Try to set a system restore point before installing a device driver. All rights reserved. When I placed the video card back in, it continued on as it was, cracklin' popping and whatnot.

Five USB connected optical drives for CD Audio production using Nero 11 Toshiba Touch Screen Laptop with Win 10 64 bit HP . Peyman My System Specs System Manufacturer/Model Number Custom Made OS Windows 7 64-Bit CPU Intel I7 950 Motherboard EVGA X58 3SLI Memory 12 GB DDR3 1600Mhz Graphics Card EVGA 2 GTX not disabled just turned off. http://pspfull.com/creative-sound/creative-sound-blaster-drivers-xp-5-1.html Also, when the installation has finished, do perform a restart to ensure that all changes take effect properly.

Please note that comments requesting support or pointing out listing errors will be deleted. I know you only have 2 PCI slots, and that the one you probably aren't using is riding up on your 4850, but just try it for a bit - you When enabled by proper files, the characteristics of the sound card (like model, manufacturer, number of channels) are completely available to computers, and all its features are made accessible.

My Audigy 2 ZS did something similar a while back - unplugging the card and putting it in a different slot (uninstall and reinstall drivers when you do so) fixed it.Edit:

I've followed almost everyone's advice, with things such as:- Wiping the drivers clean, and reinstalling- Trying older drivers- Using Daniel_K's pack- Disabling unneeded ports in bios (e.g: Parallel/Serial)- Updating chipset drivers, Is that correct? Also, when the installation has finished, do perform a restart to ensure that all changes take effect properly. My System Specs System Manufacturer/Model Number ZezasuBuilt OS Windows Seven x64 CPU Intel Core 2 Quad Q6700 3.2Ghz Motherboard GA-UD3P Intel and Crossfire ready Memory 6GB Samsung Graphics Card 5850 Sapphire

I missed you there.. I'll be purchasing a new motherboard and seeing if that helps it at all. Visit our Support Forums for help or drop an email to mgnews @ majorgeeks.com to report mistakes. Check This Out edit: the unofficial pack wont even install, i really doubt the sound card is dead after a reboot, and it was working fine before the reboot.

Device status just says "This device cannot start. (Code 10)" And other ideas? i actually recommend that you use no driver updates from windows update. Please enable JavaScript to view the comments powered by Disqus. I'm usin' the onboard for now.

Just to see what'd happen, and there was no crackling. frozenleadOct 6, 2009, 4:36 AM I wouldn't put bets on Creative's drivers. something.